Infos / Meldungen von USE

 Zur Konfigurationsseite der USE-Flags

The following REQUIRED_USE flag constraints are unsatisfied: Diese Meldung weist auf einen Konflikt in der Installation eines Paketes mit den dazugehörigen USE-Flag hin. Diese müssen angepasst werden.

Ein Beispiel:

localhost /home/michi # emerge -avuND @world

* IMPORTANT: 12 news items need reading for repository 'gentoo'.
* Use eselect news read to view new items.

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! The ebuild selected to satisfy "sys-fs/lvm2" has unmet requirements.
- sys-fs/lvm2-2.02.145-r2::gentoo USE="readline systemd thin (-clvm) (-cman) -corosync -device-mapper-only -lvm1 -lvm2create_initrd -openais (-selinux) (-static) (-static-libs) -udev" ABI_X86="(64)"

The following REQUIRED_USE flag constraints are unsatisfied:
systemd? ( udev )

The above constraints are a subset of the following complete expression:
device-mapper-only? ( !clvm !cman !corosync !lvm1 !lvm2create_initrd !openais !thin ) systemd? ( udev ) clvm? ( !systemd )

(dependency required by "sys-kernel/genkernel-next-65::gentoo" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])

The following REQUIRED_USE flag constraints are unsatisfied: systemd? ( udev )  – Diese Aussage besagt, dass wenn USE = systemd ist, dann auch USE = udev gesetzt werden muss. Verwenden Sie die Datei /etc/portage/package.use um ein use-Flag für ein Paket zu setzen. Die einmalige Verwendung bei der Kompilierung mit USE= wird beim nächsten Update  überschrieben. Soll ein Use-Flag für das gesamte System gesetzt werden geschieht das in der Datei /etc/portage/make.conf

#USE=systemd emerge -av  sys-fs/lvm2

 

!!! The following installed packages are masked:
- net-fs/samba-4.5.10-r1::gentoo (masked by: package.mask)
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

Schreibe einen Kommentar

%d Bloggern gefällt das: