The ebuild selected to satisfy „>=media-libs/libmediaart-1.9.1:2.0[introspection]“ has unmet requirements.

localhost /home/michi # emerge -avuND world
--- Invalid atom in /etc/portage/package.unmask: master-pdf-editor

 * IMPORTANT: 10 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-db/sqlite:3

  (dev-db/sqlite-3.30.1:3/3::gentoo, ebuild scheduled for merge) USE="icu readline -debug -doc -secure-delete -static-libs -tcl -test -tools" ABI_X86="(64) -32 (-x32)" pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-db/sqlite-3.30.1:3/3::gentoo, installed) USE="icu readline secure-delete -debug -doc -static-libs -tcl -test -tools" ABI_X86="(64) -32 (-x32)" pulled in by
    >=dev-db/sqlite-3.28.0:3[secure-delete,debug=] required by (mail-client/thunderbird-68.5.0:0/0::gentoo, ebuild scheduled for merge) USE="dbus gmp-autoupdate startup-notification system-av1 system-harfbuzz system-icu system-jpeg system-libevent system-libvpx system-sqlite system-webp -bindist -clang -custom-cflags -custom-optimization -debug -eme-free -hardened -jack -lightning -lto (-pgo) -pulseaudio (-selinux) -test -wayland -wifi" ABI_X86="(64)" CPU_FLAGS_X86="-avx2" L10N="de -ar -ast -be -bg -br -ca -cs -cy -da -el -en-GB -es-AR -es-ES -et -eu -fi -fr -fy -ga -gd -gl -he -hr -hsb -hu -hy -id -is -it -ja -ko -lt -nb -nl -nn -pl -pt-BR -pt-PT -rm -ro -ru -si -sk -sl -sq -sr -sv -tr -uk -vi -zh-CN -zh-TW"
                             ^^^^^^^^^^^^^                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                              
    >=dev-db/sqlite-3.28.0:3[secure-delete,debug=] required by (www-client/firefox-68.5.0:0/0::gentoo, ebuild scheduled for merge) USE="dbus gmp-autoupdate screenshot startup-notification system-av1 system-harfbuzz system-icu system-jpeg system-libevent system-libvpx system-sqlite system-webp -bindist -clang -custom-cflags -custom-optimization -debug -eme-free -geckodriver -hardened -hwaccel -jack -lto -pgo -pulseaudio (-selinux) -test -wayland -wifi" ABI_X86="(64)" CPU_FLAGS_X86="-avx2" L10N="de -ach -af -an -ar -ast -az -be -bg -bn -br -bs -ca -cak -cs -cy -da -dsb -el -en-CA -en-GB -eo -es-AR -es-CL -es-ES -es-MX -et -eu -fa -ff -fi -fr -fy -ga -gd -gl -gn -gu -he -hi -hr -hsb -hu -hy -ia -id -is -it -ja -ka -kab -kk -km -kn -ko -lij -lt -lv -mk -mr -ms -my -nb -nl -nn -oc -pa -pl -pt-BR -pt-PT -rm -ro -ru -si -sk -sl -son -sq -sr -sv -ta -te -th -tr -uk -ur -uz -vi -xh -zh-CN -zh-TW"
                             ^^^^^^^^^^^^^                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                            

dev-libs/libcdio:0

  (dev-libs/libcdio-2.1.0-r1:0/19::gentoo, ebuild scheduled for merge) USE="cxx -cddb -minimal -static-libs -test" ABI_X86="(64) -32 (-x32)" pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/libcdio-2.0.0-r1:0/18::gentoo, installed) USE="cxx -cddb -minimal -static-libs -test" ABI_X86="(64) -32 (-x32)" pulled in by
    >=dev-libs/libcdio-0.94:0/18=[abi_x86_64(-)] required by (dev-libs/libcdio-paranoia-0.94_p2-r2:0/0::gentoo, installed) USE="cxx -static-libs -test" ABI_X86="(64) -32 (-x32)"
                           ^^^^^^                                                                                                                                                                                                                                                                                                      
dev-libs/libcdio:0

  (dev-libs/libcdio-2.1.0-r1:0/19::gentoo, ebuild scheduled for merge) USE="cxx -cddb -minimal -static-libs -test" ABI_X86="(64) -32 (-x32)" pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/libcdio-2.0.0-r1:0/18::gentoo, installed) USE="cxx -cddb -minimal -static-libs -test" ABI_X86="(64) -32 (-x32)" pulled in by
    >=dev-libs/libcdio-0.94:0/18=[abi_x86_64(-)] required by (dev-libs/libcdio-paranoia-0.94_p2-r2:0/0::gentoo, installed) USE="cxx -static-libs -test" ABI_X86="(64) -32 (-x32)"
                           ^^^^^^                                                                                                                                                                                                                                                                                                      

app-crypt/pinentry:0

  (app-crypt/pinentry-1.1.0-r2:0/0::gentoo, ebuild scheduled for merge) USE="gtk ncurses qt5 -caps -emacs -fltk -gnome-keyring -static" ABI_X86="(64)" pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (app-crypt/pinentry-1.1.0-r2:0/0::gentoo, installed) USE="gnome-keyring gtk ncurses qt5 -caps -emacs -fltk -static" ABI_X86="(64)" pulled in by
    app-crypt/pinentry[gnome-keyring] required by (gnome-base/gnome-keyring-3.31.91-r1:0/0::gentoo, installed) USE="caps filecaps pam ssh-agent (-selinux) -test" ABI_X86="(64)"
                       ^^^^^^^^^^^^^                                                                                                                                                                                                                                                                                                                     


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


!!! The ebuild selected to satisfy ">=media-libs/libmediaart-1.9.1:2.0[introspection]" has unmet requirements.
- media-libs/libmediaart-1.9.4::gentoo USE="gtk introspection qt5 -test -vala" ABI_X86="(64)" 

  The following REQUIRED_USE flag constraints are unsatisfied:
    at-most-one-of ( gtk qt5 )

  The above constraints are a subset of the following complete expression:
    at-most-one-of ( gtk qt5 ) vala? ( introspection )

(dependency required by "media-sound/gnome-music-3.32.2-r1::gentoo" [installed])
(dependency required by "gnome-base/gnome-extra-apps-3.32.2::gentoo[tracker]" [installed])
(dependency required by "gnome-base/gnome-3.32.2::gentoo[extras]" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])

Das Problem wurde durch Hinzufügen von libart in die package.mask gelöst

Quellcode

michi@localhost ~ $ nano -w /etc/portage/package.mask
media-libs/libmediaart

OpenSSL bindist Probleme

https://bugs.gentoo.org/531540

dev-libs/openssl:0

  (dev-libs/openssl-1.0.2-r1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/openssl:0[-bindist] required by (dev-qt/qtnetwork-5.4.0:5/5::gentoo, ebuild scheduled for merge)
                       ^^^^^^^^                                                                                                                 

  (dev-libs/openssl-1.0.2-r1:0/0::gentoo, installed) pulled in by
    >=dev-libs/openssl-0.9.6d:0[bindist=] required by (net-misc/openssh-6.7_p1-r3:0/0::gentoo, installed)

Ein USE=“bindist“ emerge -av openssl brachte keine Besserung.

Ich habe temporär – bindist in die /etc/portage/make.conf eingetragen um das Paket kompilieren zu können.

net-libs/telepathy-glib-0.24.1-r1 fails to build with python 3.6

Beim Kompilieren von Gnome trat ein Fehler auf:

make: *** [Makefile:398: all] Error 2 ERROR: net-libs/telepathy-glib-0.24.1-r1::gentoo failed (compile phase):emake failed

/usr/bin/python3.6 ../tools/xincludator.py account.xml > _gen/tp-spec-account.xml.tmp
/usr/bin/python3.6 ../tools/xincludator.py account-manager.xml > _gen/tp-spec-account-manager.xml.tmp
/usr/bin/python3.6 ../tools/xincludator.py call-content.xml > _gen/tp-spec-call-content.xml.tmp
/usr/bin/python3.6 ../tools/xincludator.py call-content-media-description.xml > _gen/tp-spec-call-content-media-description.xml.tmp
/usr/bin/python3.6 ../tools/xincludator.py call-stream.xml > _gen/tp-spec-call-stream.xml.tmp
Traceback (most recent call last):
  File "../tools/xincludator.py", line 45, in <module>
    stdout.write(xml)
UnicodeEncodeError: 'ascii' codec can't encode character '\xa9' in position 293: ordinal not in range(128)
Traceback (most recent call last):
  File "../tools/xincludator.py", line 45, in <module>
    stdout.write(xml)
UnicodeEncodeError: 'ascii' codec can't encode character '\xa9' in position 393: ordinal not in range(128)
make[2]: *** [Makefile:1929: _gen/tp-spec-account-manager.xml] Error 1
make[2]: *** Waiting for unfinished jobs....
make[2]: *** [Makefile:1929: _gen/tp-spec-call-content-media-description.xml] Error 1
Traceback (most recent call last):
  File "../tools/xincludator.py", line 45, in <module>
    stdout.write(xml)
UnicodeEncodeError: 'ascii' codec can't encode character '\xa9' in position 269: ordinal not in range(128)
Traceback (most recent call last):
  File "../tools/xincludator.py", line 45, in <module>
    stdout.write(xml)
UnicodeEncodeError: 'ascii' codec can't encode character '\xa9' in position 327: ordinal not in range(128)
make[2]: *** [Makefile:1929: _gen/tp-spec-account.xml] Error 1
make[2]: *** [Makefile:1929: _gen/tp-spec-call-content.xml] Error 1
Traceback (most recent call last):
  File "../tools/xincludator.py", line 45, in <module>
    stdout.write(xml)
UnicodeEncodeError: 'ascii' codec can't encode character '\xa9' in position 324: ordinal not in range(128)
make[2]: *** [Makefile:1929: _gen/tp-spec-call-stream.xml] Error 1
make[2]: Leaving directory '/var/tmp/portage/net-libs/telepathy-glib-0.24.1-r1/work/telepathy-glib-0.24.1/telepathy-glib'
make[1]: *** [Makefile:468: all-recursive] Error 1
make[1]: Leaving directory '/var/tmp/portage/net-libs/telepathy-glib-0.24.1-r1/work/telepathy-glib-0.24.1'
make: *** [Makefile:398: all] Error 2
 * ERROR: net-libs/telepathy-glib-0.24.1-r1::gentoo failed (compile phase):
 *   emake failed
 * 
 * If you need support, post the output of `emerge --info '=net-libs/telepathy-glib-0.24.1-r1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=net-libs/telepathy-glib-0.24.1-r1::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/net-libs/telepathy-glib-0.24.1-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-libs/telepathy-glib-0.24.1-r1/temp/environment'.
 * Working directory: '/var/tmp/portage/net-libs/telepathy-glib-0.24.1-r1/work/telepathy-glib-0.24.1'
 * S: '/var/tmp/portage/net-libs/telepathy-glib-0.24.1-r1/work/telepathy-glib-0.24.1'

>>> Failed to emerge net-libs/telepathy-glib-0.24.1-r1, Log file:

>>>  '/var/tmp/portage/net-libs/telepathy-glib-0.24.1-r1/temp/build.log'

 * Messages for package net-libs/telepathy-glib-0.24.1-r1:

 * ERROR: net-libs/telepathy-glib-0.24.1-r1::gentoo failed (compile phase):
 *   emake failed
 * 
 * If you need support, post the output of `emerge --info '=net-libs/telepathy-glib-0.24.1-r1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=net-libs/telepathy-glib-0.24.1-r1::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/net-libs/telepathy-glib-0.24.1-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-libs/telepathy-glib-0.24.1-r1/temp/environment'.
 * Working directory: '/var/tmp/portage/net-libs/telepathy-glib-0.24.1-r1/work/telepathy-glib-0.24.1'
 * S: '/var/tmp/portage/net-libs/telepathy-glib-0.24.1-r1/work/telepathy-glib-0.24.1'
localhost /ho

Der Fehler wird auf folgender Seite beschrieben: https://bugs.gentoo.org/702338
Bei mir wurde das Problem durch Änderung der make.conf behoben:

localhost /home/michi # nano -w /etc/portage/make.conf 
# This sets the language of build output to English.
# Please keep this setting intact when reporting bugs.

L10N="de"
LC_CTYPE=de_DE.UTF-8

Superuser Root mit su werden

Warum kann ein Benutzer nicht su verwenden, um root zu werden?

Aus Sicherheitsgründen dürfen nur Benutzer, die in der wheel Gruppe sind, su benutzen. Um einen Benutzer dieser Gruppe hinzuzufügen, führe den folgenden Befehl als root aus:

root #gpasswd -a benutzername wheel

Mit dem Kommando su („substitute user“) wechseln Sie auf der Kommandozeile die Identität. Dazu startet im Hintergrund eine neue Shell unter einer neuen Benutzerkennung (UID) und Gruppenkennung (GID). Um mit su Administrator oder ein anderer Benutzer zu werden, müssen Sie das entsprechende Passwort kennen.

Grundsätzlich lautet das Kommando su [-] [benutzername] – dabei gibt es den kleinen aber feinen Unterschied, ob Sie das Minuszeichen verwenden oder nicht. Das Minuszeichen (alternativ können Sie hier den Parameter -l oder seine Langform --login verwenden) sorgt dafür, dass ein wirkliches Einloggen stattfindet – mit Setzen der richtigen Umgebungsvariablen, Shell und einem Wechsel in das neue Home-Verzeichnis. Ohne das Minuszeichen ändern sich die Umgebungsvariablen nicht, und der neue User besitzt eventuell keine Rechte, sich im aktuellen Arbeitsverzeichnis aufzuhalten

x11-misc/xidle-26052015::gentoo (masked by: ~amd64 keyword)

localhost /home/michi # emerge -av xidle

  • IMPORTANT: 8 news items need reading for repository ‚gentoo‘.
  • Use eselect news read to view new items.

These are the packages that would be merged, in order:

Calculating dependencies… done!

!!! All ebuilds that could satisfy „xidle“ have been masked.
!!! One of the following masked packages is required to complete your request:

  • x11-misc/xidle-26052015::gentoo (masked by: ~amd64 keyword)

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

Das kann durch das Hinzufügen des Paketes x11-misc/xidle in die Datei /etc/portage/package.accept_keywords gelöst werden.

localhost /home/michi # nano -w /etc/portage/package.accept_keywords

x11-misc/xidle    ~amd64

GRUB mit UEFI

localhost /home/michi # os-prober
  WARNING: Failed to connect to lvmetad. Falling back to device scanning.
  /dev/sdb: open failed: No medium found
localhost /home/michi # 
localhost /home/michi # mount
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
none on /run type tmpfs (rw,nosuid,nodev,relatime,mode=755)
udev on /dev type devtmpfs (rw,nosuid,relatime,size=10240k,nr_inodes=2036784,mode=755)
devpts on /dev/pts type devpts (rw,relatime,gid=5,mode=620,ptmxmode=000)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
/dev/sda4 on / type ext4 (rw,relatime)
debugfs on /sys/kernel/debug type debugfs (rw,nosuid,nodev,noexec,relatime)
configfs on /sys/kernel/config type configfs (rw,nosuid,nodev,noexec,relatime)
fusectl on /sys/fs/fuse/connections type fusectl (rw,nosuid,nodev,noexec,relatime)
efivarfs on /sys/firmware/efi/efivars type efivarfs (rw,nosuid,nodev,noexec,relatime)
cgroup_root on /sys/fs/cgroup type tmpfs (rw,nosuid,nodev,noexec,relatime,size=10240k,mode=755)
openrc on /sys/fs/cgroup/openrc type cgroup (rw,nosuid,nodev,noexec,relatime,release_agent=/lib/rc/sh/cgroup-release-agent.sh,name=openrc)
none on /sys/fs/cgroup/unified type cgroup2 (rw,nosuid,nodev,noexec,relatime,nsdelegate)
cpuset on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)
cpuacct on /sys/fs/cgroup/cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpuacct)
mqueue on /dev/mqueue type mqueue (rw,nosuid,nodev,noexec,relatime)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,nosuid,nodev,noexec,relatime)
localhost /home/michi # 
# /etc/fstab: static file system information.
#
# noatime turns off atimes for increased performance (atimes normally aren't 
# needed); notail increases performance of ReiserFS (at the expense of storage 
# efficiency).  It's safe to drop the noatime options if you want and to 
# switch between notail / tail freely.
#
# The root filesystem should have a pass number of either 0 or 1.
# All other filesystems should have a pass number of 0 or greater than 1.
#
# See the manpage fstab(5) for more information.
#

# <fs>                  <mountpoint>    <type>          <opts>          <dump/pass>

# NOTE: If your BOOT partition is ReiserFS, add the notail option to opts.
#
# NOTE: Even though we list ext4 as the type here, it will work with ext2/ext3
#       filesystems.  This just tells the kernel to use the ext4 driver.
#
# NOTE: You can use full paths to devices like /dev/sda3, but it is often
#       more reliable to use filesystem labels or UUIDs. See your filesystem
#       documentation for details on setting a label. To obtain the UUID, use
#       the blkid(8) command.

#LABEL=boot             /boot           ext4            noauto,noatime  1 2
#UUID=58e72203-57d1-4497-81ad-97655bd56494              /               ext4            noatime         0 1
#LABEL=swap             none            swap            sw              0 0
#/dev/cdrom             /mnt/cdrom      auto            noauto,ro       0 0
/dev/sda3               /
/dev/sda5               /boot           vfat
/etc/fstab lines 1-31/31 (END)

kein Sound unter Gentoo? – hier gibts die Lösung

Die weitverbreiteste Lösung für den Sound unter Gentoo ist Alsa. Es gibt aber zum Beispiel auch Pulseaudio. Das wiki zum Alsa unter Gentoo gibt es hier : https://wiki.gentoo.org/wiki/ALSA

Hier gibt es einige Tipps um zu überprüfen warum der Sound nicht funktioniert:

Es muss Alsa installiert sein. Es ist empfehlenswert es in die /etc/portage/make.conf hinzuzufügen. Sollte das noch nicht der Fall gewesen sein ist es erforderlich hinterher ein Update durchzuführen.

#emerge -avuND world

Wer eine grafische Oberfläche für Alsa haben möchte um den Sound zu konfigurieren dem empfehle ich alsamixergui zu installieren.

#emerge -av alsamixergui
Alsamixergui

Es ist wichtig zu überprüfen ob Alsa beim booten gestartet wird.

michi@localhost ~ $ rc-update
            alsasound | boot                                   
               binfmt | boot                                   
             bootmisc | boot                                   
              cgroups |                                 sysinit
                devfs |                                 sysinit
                dmesg |                                 sysinit
                 fsck | boot                                   
             hostname | boot                                   
              hwclock | boot                                   
              keymaps | boot                                   
            killprocs |                        shutdown        
    kmod-static-nodes |                                 sysinit
                local |      default nonetwork                 
           localmount | boot                                   
             loopback | boot                                   
              modules | boot                                   
             mount-ro |                        shutdown        
                 mtab | boot                                   
             netmount |      default                           
     opentmpfiles-dev |                                 sysinit
   opentmpfiles-setup | boot                                   
               procfs | boot                                   
                 root | boot                                   
         save-keymaps | boot                                   
    save-termencoding | boot                                   
            savecache |                        shutdown        
                 swap | boot                                   
               sysctl | boot                                   
                sysfs |                                 sysinit
         termencoding | boot                                   
                 udev |                                 sysinit
         udev-trigger |                                 sysinit
              urandom | boot                                   
michi@localhost ~ $ 

Ist dies nicht der Fall kann alsasound durch folgenden Befehl hinzugefügt werden:

#rc-update add alsasound boot

Hier wird Nix angezeigt, weil Nix erkannt wurde. Das kann über eine Suche in der dmesg getestet werden.

michi@localhost ~ $ dmesg | grep audio
[    5.744783] snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC887-VD: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:line
[    5.744784] snd_hda_codec_realtek hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    5.744785] snd_hda_codec_realtek hdaudioC0D0:    hp_outs=1 (0x1b/0x0/0x0/0x0/0x0)
[    5.744786] snd_hda_codec_realtek hdaudioC0D0:    mono: mono_out=0x0
[    5.744786] snd_hda_codec_realtek hdaudioC0D0:    dig-out=0x11/0x0
[    5.744787] snd_hda_codec_realtek hdaudioC0D0:    inputs:
[    5.744788] snd_hda_codec_realtek hdaudioC0D0:      Front Mic=0x19
[    5.744788] snd_hda_codec_realtek hdaudioC0D0:      Rear Mic=0x18
[    5.744789] snd_hda_codec_realtek hdaudioC0D0:      Line=0x1a
[    5.758442] snd_hda_codec_generic hdaudioC0D2: autoconfig for Generic: line_outs=0 (0x0/0x0/0x0/0x0/0x0) type:line
[    5.758443] snd_hda_codec_generic hdaudioC0D2:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    5.758444] snd_hda_codec_generic hdaudioC0D2:    hp_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    5.758444] snd_hda_codec_generic hdaudioC0D2:    mono: mono_out=0x0
[    5.758445] snd_hda_codec_generic hdaudioC0D2:    inputs:
michi@localhost ~ $ ^C

Der User, der den Sound nutzen will muss in der Gruppe audio hinterlegt sein.

/etc/profile/make.profile is not a symlink

/etc/portage/make.profile is not a symlink and will probably prevent most merges. !!! It should point into a profile within /usr/portage/profiles/ !!! (You can safely ignore this message when syncing. It’s harmless.)

Um diesem Fehler auf den Grund zu gehen erst einmal ein emerge –sync durchführen

Falls dies keine Besserung bringt: die Datei /etc/portage/make.profile löschen

root# rm /etc/portage/make.profile

Bitte beachten: wenn man nicht in der chroot-Umgebung ist , muss der Pfad dazu mit angeben werden. Zum Beispiel:

livecd# rm /mnt/gentoo/etc/portage/make.profile

Der nächste Schritt muss auf jeden Fall in der chroot-Umgebung durchgeführt werden:

root# eselect profile list
eselect profile list zeigt verfügbare Profile an

Jetzt ein Profil auswählen und durch #eselect profile set x setzen

root#eslect profile set 20

Jetzt sollte das Problem gelöst sein