spyder [4886:4886:1226/125338.508505:ERROR:zygote_host_impl_linux.c

localhost /home/michi # spyder
[4886:4886:1226/125338.508505:ERROR:zygote_host_impl_linux.cc(89)] Running as root without --no-sandbox is not supported. See https://crbug.com/638180.

localhost /home/michi # spyder --no-sandboxusage: spyder [options] filesspyder: error: unrecognized arguments: --no-sandbox

Die Lösung ist: es kann spyder nur als User ausgeführt werden. Also durch #su username zum User wechseln und den Befehl spyder nochmals ausführen

grub-install: error: /usr/lib/grub/x86_64-efi/modinfo.sh doesn’t exist.

localhost ~ # grub-install /dev/sda
grub-install: error: /usr/lib/grub/x86_64-efi/modinfo.sh doesn’t exist. Please specify –target or –directory.

Grundlegende Infos zu GRUB unter Gentoo gibt es hier: https://wiki.gentoo.org/wiki/GRUB2

Bei diesem Fehler wurde ein guter Beitrag zur Recherche von Fehlern und erforderlichen Infos im Gentoo-Forum erstellt:

https://forums.gentoo.org/viewtopic-p-8543335.html?fbclid=IwAR0cR9AfLECScq6dsYJzUW6ZzIcI8Nxe5rqY4cVsyAxgHT49ZT_kOh6Ubow#8543335

!!! The ebuild selected to satisfy „dev-tcltk/tclpython“ has unmet requirements.

sysvorOrt /home/michi # emerge -avuND world

 * IMPORTANT: 10 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


These are the packages that would be merged, in order:

Calculating dependencies \

!!! Problem resolving dependencies for dev-tcltk/tclpython from @selected
... done!

!!! The ebuild selected to satisfy "dev-tcltk/tclpython" has unmet requirements.
- dev-tcltk/tclpython-5.0::gentoo USE="" ABI_X86="(64)" PYTHON_SINGLE_TARGET="-python3_6 -python3_7"

  The following REQUIRED_USE flag constraints are unsatisfied:
    exactly-one-of ( python_single_target_python3_6 python_single_target_python3_7 )

(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
sysvorOrt /home/michi # 

Um dieses Problem zu beheben ist ein Eintrag in der /etc/portage/package.use erforderlich:

dev-tcltk/tclpython python_single_target_python3_7 

Die Version von Python (3_7) kann natürlich angepasst werden falls gewünscht.