Forbidden You don’t have permission to access this resource.Server unable to read htaccess file, denying access to be safe Apache Server at localhost Port 80

Forbidden

You don’t have permission to access this resource.Server unable to read htaccess file, denying access to be safe


Apache Server at localhost Port 80

In diesem Fall gibt es ein Rechteproblem in der Konfiguration des Apache
Häufig versucht man auf Dateien im Verzeichnis zuzugreifen die vom Root konfiguriert wurde aber für die User nicht freigegeben wurde. Das kann durch chmod geändert werden. Als root chmod 777 ausführen gibt die Dateien frei.

michi@localhost ~ $ cd /var/www/localhost/htdocs/
michi@localhost /var/www/localhost/htdocs $ ls -all
insgesamt 24
drwxrwxrwx 2 michi root 4096 28. Mär 16:17 .
drwxr-xr-x 3 root  root 4096 28. Mär 11:57 ..
-rwxrwxrwx 1 michi root   45 28. Mär 11:57 index.html
-rwxrwxrwx 1 michi root   27 28. Mär 16:13 info.html
-rwxrwxrwx 1 michi root   31 28. Mär 16:11 info.php
-rwxrwxrwx 1 michi root   20 28. Mär 16:17 test.php.save
michi@localhost /var/www/localhost/htdocs $ 

mkfs.vfat command not found

Wenn beim Aufrufen von mkfs.vfat oder mkfs.fat der Fehler command not found kommt muss warscheinlich das Paket dosfstools installiert werden.

localhost /home/michi # emerge -av dosfstools                                                                                                                                                   
                                                                                                          

 * IMPORTANT: 10 news items need reading for repository 'gentoo'.                                                                                                                               
 * Use eselect news read to view new items.                                                                                                                                                     


These are the packages that would be merged, in order:                                                                                                                                          

Calculating dependencies... done!                                                                                                                                                               
[ebuild  N     ] sys-fs/dosfstools-4.1::gentoo  USE="udev -compat -test" 169 KiB                                                                                                                

Total: 1 package (1 new), Size of downloads: 169 KiB                                                                                                                                            

Would you like to merge these packages? [Yes/No] yes                                                                                                                                            

>>> Verifying ebuild manifests                                                                                                                                                                  

Hinweis: mkfs.vfat ist ein Symlink zu mkfs.fat. Es handelt sich um dasselbe Dienstprogramm.

The ebuild selected to satisfy „>=media-libs/libmediaart-1.9.1:2.0[introspection]“ has unmet requirements.

localhost /home/michi # emerge -avuND world
--- Invalid atom in /etc/portage/package.unmask: master-pdf-editor

 * IMPORTANT: 10 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-db/sqlite:3

  (dev-db/sqlite-3.30.1:3/3::gentoo, ebuild scheduled for merge) USE="icu readline -debug -doc -secure-delete -static-libs -tcl -test -tools" ABI_X86="(64) -32 (-x32)" pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-db/sqlite-3.30.1:3/3::gentoo, installed) USE="icu readline secure-delete -debug -doc -static-libs -tcl -test -tools" ABI_X86="(64) -32 (-x32)" pulled in by
    >=dev-db/sqlite-3.28.0:3[secure-delete,debug=] required by (mail-client/thunderbird-68.5.0:0/0::gentoo, ebuild scheduled for merge) USE="dbus gmp-autoupdate startup-notification system-av1 system-harfbuzz system-icu system-jpeg system-libevent system-libvpx system-sqlite system-webp -bindist -clang -custom-cflags -custom-optimization -debug -eme-free -hardened -jack -lightning -lto (-pgo) -pulseaudio (-selinux) -test -wayland -wifi" ABI_X86="(64)" CPU_FLAGS_X86="-avx2" L10N="de -ar -ast -be -bg -br -ca -cs -cy -da -el -en-GB -es-AR -es-ES -et -eu -fi -fr -fy -ga -gd -gl -he -hr -hsb -hu -hy -id -is -it -ja -ko -lt -nb -nl -nn -pl -pt-BR -pt-PT -rm -ro -ru -si -sk -sl -sq -sr -sv -tr -uk -vi -zh-CN -zh-TW"
                             ^^^^^^^^^^^^^                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                              
    >=dev-db/sqlite-3.28.0:3[secure-delete,debug=] required by (www-client/firefox-68.5.0:0/0::gentoo, ebuild scheduled for merge) USE="dbus gmp-autoupdate screenshot startup-notification system-av1 system-harfbuzz system-icu system-jpeg system-libevent system-libvpx system-sqlite system-webp -bindist -clang -custom-cflags -custom-optimization -debug -eme-free -geckodriver -hardened -hwaccel -jack -lto -pgo -pulseaudio (-selinux) -test -wayland -wifi" ABI_X86="(64)" CPU_FLAGS_X86="-avx2" L10N="de -ach -af -an -ar -ast -az -be -bg -bn -br -bs -ca -cak -cs -cy -da -dsb -el -en-CA -en-GB -eo -es-AR -es-CL -es-ES -es-MX -et -eu -fa -ff -fi -fr -fy -ga -gd -gl -gn -gu -he -hi -hr -hsb -hu -hy -ia -id -is -it -ja -ka -kab -kk -km -kn -ko -lij -lt -lv -mk -mr -ms -my -nb -nl -nn -oc -pa -pl -pt-BR -pt-PT -rm -ro -ru -si -sk -sl -son -sq -sr -sv -ta -te -th -tr -uk -ur -uz -vi -xh -zh-CN -zh-TW"
                             ^^^^^^^^^^^^^                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                            

dev-libs/libcdio:0

  (dev-libs/libcdio-2.1.0-r1:0/19::gentoo, ebuild scheduled for merge) USE="cxx -cddb -minimal -static-libs -test" ABI_X86="(64) -32 (-x32)" pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/libcdio-2.0.0-r1:0/18::gentoo, installed) USE="cxx -cddb -minimal -static-libs -test" ABI_X86="(64) -32 (-x32)" pulled in by
    >=dev-libs/libcdio-0.94:0/18=[abi_x86_64(-)] required by (dev-libs/libcdio-paranoia-0.94_p2-r2:0/0::gentoo, installed) USE="cxx -static-libs -test" ABI_X86="(64) -32 (-x32)"
                           ^^^^^^                                                                                                                                                                                                                                                                                                      
dev-libs/libcdio:0

  (dev-libs/libcdio-2.1.0-r1:0/19::gentoo, ebuild scheduled for merge) USE="cxx -cddb -minimal -static-libs -test" ABI_X86="(64) -32 (-x32)" pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/libcdio-2.0.0-r1:0/18::gentoo, installed) USE="cxx -cddb -minimal -static-libs -test" ABI_X86="(64) -32 (-x32)" pulled in by
    >=dev-libs/libcdio-0.94:0/18=[abi_x86_64(-)] required by (dev-libs/libcdio-paranoia-0.94_p2-r2:0/0::gentoo, installed) USE="cxx -static-libs -test" ABI_X86="(64) -32 (-x32)"
                           ^^^^^^                                                                                                                                                                                                                                                                                                      

app-crypt/pinentry:0

  (app-crypt/pinentry-1.1.0-r2:0/0::gentoo, ebuild scheduled for merge) USE="gtk ncurses qt5 -caps -emacs -fltk -gnome-keyring -static" ABI_X86="(64)" pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (app-crypt/pinentry-1.1.0-r2:0/0::gentoo, installed) USE="gnome-keyring gtk ncurses qt5 -caps -emacs -fltk -static" ABI_X86="(64)" pulled in by
    app-crypt/pinentry[gnome-keyring] required by (gnome-base/gnome-keyring-3.31.91-r1:0/0::gentoo, installed) USE="caps filecaps pam ssh-agent (-selinux) -test" ABI_X86="(64)"
                       ^^^^^^^^^^^^^                                                                                                                                                                                                                                                                                                                     


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


!!! The ebuild selected to satisfy ">=media-libs/libmediaart-1.9.1:2.0[introspection]" has unmet requirements.
- media-libs/libmediaart-1.9.4::gentoo USE="gtk introspection qt5 -test -vala" ABI_X86="(64)" 

  The following REQUIRED_USE flag constraints are unsatisfied:
    at-most-one-of ( gtk qt5 )

  The above constraints are a subset of the following complete expression:
    at-most-one-of ( gtk qt5 ) vala? ( introspection )

(dependency required by "media-sound/gnome-music-3.32.2-r1::gentoo" [installed])
(dependency required by "gnome-base/gnome-extra-apps-3.32.2::gentoo[tracker]" [installed])
(dependency required by "gnome-base/gnome-3.32.2::gentoo[extras]" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])

Das Problem wurde durch Hinzufügen von libart in die package.mask gelöst

Quellcode

michi@localhost ~ $ nano -w /etc/portage/package.mask
media-libs/libmediaart